CLI gets stuck at end on log.dispose and doesn't create test report

Below is my entire log. This is happening on multiple pc’s with multiple versions of oxygen-cli installed. Could really use some help with this. It sits on “log.dispose” forever. I’ve let it sit for hours and nothing happens. It never creates the log file either.

Microsoft Windows [Version 10.0.18362.836]
© 2019 Microsoft Corporation. All rights reserved.

C:\Oxygen\First>oxygen suite.json
Test started…
info: [WorkerProcess] Starting worker process 4886837f.
info: [Oxygen] Loading services…
info: [Oxygen] Loading modules…
info: [Oxygen] Loading module: assert [ 0.042 sec ]
info: [Oxygen] Loading module: date [ 0.002 sec ]
error: [Oxygen] Error initializing module “db”: unixodbc binaries not installed

info: [Oxygen] Loading module: email [ 0.029 sec ]
info: [Oxygen] Loading module: eyes [ 0.004 sec ]
info: [Oxygen] Loading module: http [ 0.203 sec ]
info: [Oxygen] Loading module: log [ 0.001 sec ]
info: [Oxygen] Loading module: mailinator [ 0.001 sec ]
info: [Oxygen] Loading module: mob [ 0.331 sec ]
info: [Oxygen] Loading module: pdf [ 0.108 sec ]
info: [Oxygen] Loading module: serial [ 0.028 sec ]
info: [Oxygen] Loading module: shell [ 0.001 sec ]
info: [Oxygen] Loading module: soap [ 0.104 sec ]
info: [Oxygen] Loading module: twilio [ 0.001 sec ]
info: [Oxygen] Loading module: web [ 0.129 sec ]
info: [Oxygen] Loading module: win [ 0.019 sec ]
Oxygen Worker initialized in 1437 ms
Test 4886837f has started…
Suite “suite” has started…

  • Case “case1” has started…
    info: [Oxygen] Executing: eyes.onBeforeCase()
    info: [Oxygen] Executing: log.onBeforeCase()
    info: [Oxygen] Executing: mob.onBeforeCase()
    info: [Oxygen] Executing: mob._iterationStart()
    info: [Oxygen] Executing: web.onBeforeCase()
    info: [Oxygen] Executing: web._iterationStart()
    info: [Oxygen] Executing: win.onBeforeCase()
    info: [Oxygen] Executing: win._iterationStart()
    info: [Oxygen] Executing: log.error(“Hello World!”)
    • Step “error” has started…
      error: [Module:log] Hello World!
      info: [Oxygen] Executing: eyes.onAfterCase(null)
    • Step “log.error(“Hello World!”)” has ended in 0.00s with status: PASSED.
      info: [Oxygen] Executing: log.onAfterCase(null)
      info: [Oxygen] Executing: mob.onAfterCase(null)
      info: [Oxygen] Executing: mob._iterationEnd()
      info: [Oxygen] Executing: web.onAfterCase(null)
      info: [Oxygen] Executing: web._iterationEnd()
      info: [Oxygen] Executing: win.onAfterCase(null)
      info: [Oxygen] Executing: win._iterationEnd()
  • Case “case1” has ended with status: PASSED.
    info: [Oxygen] Executing: eyes.dispose(“passed”)
    info: [Oxygen] Executing: log.dispose(“passed”)

Which version of cli? What OS version? What web driver version? Don’t know the answer but this might help narrow it down. Also node version. You could try “npm view oxygen-cli versions” this will let you see what other versions of oxygen you could try. Install a different version with ‘npm install oxygen-cli@1.x.x’

I’ve tried cli 1.1.0, 1.2.0, and 1.3.0 and it doesn’t work. I’m using the latest selenium grid version and chrome driver, but my test is literally just “log.error(“Hello World!”);” and I installed the stable version of nodejs (12 dot something)

Im running windows 10 and it’s up to date

1 Like

I see a branch in the git that appears to address this issue.

I would try a different node version if that is possible or you could try to use this branch.

I tried using that branch and it appears to do the same thing. Is there a node version you’d recommend I try? I am currently on 12.16.3. Also, I got that branch by using npm to grab the version outlined in the package file. Is there another way to get the version? Maybe i did that wrong

I was told to try using nvm as the version manager of node. I would recommend any long term support version of node. I use 13.9 in the ide but on our server I have been using 10.6. I would try anything below 12.11 as I am guessing the person who put this bug in did test other versions. As far as how to run this branch. I used git and cloned the github then checked out the branch and installed it. Used the commands in the package.json file. npm run-script xxx. I am sure one of the great people from this project will address your concerns also. They are very good at helping people here.

Thank you @testerMike for your help with this. Downgrading node to 12.9.1 fixed my problem! I really appreciate your time and patience helping out a newbie

1 Like

By the way, we are just about to launch official support to node 12
Will keep you posted, please also follow our official releases